胜利大逃亡[HDU1253]

时间:2023-03-09 05:45:51
胜利大逃亡[HDU1253]

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21853    Accepted Submission(s): 8565

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

胜利大逃亡[HDU1253]

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output
11

Author
Ignatius.L

Recommend
Ignatius.L

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;
struct node
{
int x,y,z,step;
};
const int dx[6]={-1,1,0,0,0,0};
const int dy[6]={0,0,-1,1,0,0};
const int dz[6]={0,0,0,0,-1,1};
int A,B,C,T;
int g[60][60][60];
bool f[150000];
int hash(int x,int y,int z)
{
return x*B*C+y*C+z;
}
int bfs()
{
node S;
int i;
S.x=S.y=S.z=S.step=0;
queue<node> q;
while (!q.empty()) q.pop();
q.push(S);
memset(f,false,sizeof(f));
f[0]=true;
while (!q.empty())
{
node cur=q.front();
q.pop();
if (cur.x==A-1 && cur.y==B-1 && cur.z==C-1) return cur.step;
if (cur.step==T) return -1;
for (i=0;i<6;i++)
{
node tmp=cur;
tmp.x+=dx[i];
tmp.y+=dy[i];
tmp.z+=dz[i];
tmp.step++;
if (tmp.x<0 || tmp.y<0 || tmp.z<0 || g[tmp.x][tmp.y][tmp.z]==1 || tmp.x>=A || tmp.y>=B || tmp.z>=C) continue;
int H=hash(tmp.x,tmp.y,tmp.z);
if (!f[H])
{
f[H]=true;
q.push(tmp);
}
}
}
return -1;
}
int main()
{
int K,i,j,k;
scanf("%d",&K);
while (K--)
{
scanf("%d%d%d%d",&A,&B,&C,&T);
for (i=0;i<A;i++)
for (j=0;j<B;j++)
for (k=0;k<C;k++)
scanf("%d",&g[i][j][k]);
int ans=bfs();
printf("%d\n",ans);
}
return 0;
}