Train Problem II(卡特兰数 组合数学)

时间:2023-03-08 21:49:28

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1023

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12035    Accepted Submission(s): 6422

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
Output
For each test case, you should output how many ways that all the trains can get out of the railway.
Sample Input
1
2
3
10
Sample Output
1
2
5
16796
Hint

The result will be very large, so you may not process it by 32-bit integers.

Author
Ignatius.L
Recommend
We have carefully selected several similar problems for you:  1133 1022 1130 1131 1134 
题目大意:问你有n辆火车,要求进站顺序是1-n  问你有多少种出站次序
思路:要用到大数,所以推荐用java来写,方便很多。  这题就是一个卡特兰数的板子
看代码:
import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner; public class Main { public static void main(String args[]) { Scanner cin = new Scanner(System.in); /*
* 卡特兰数性质:h[n]=h[n-1]*(4n-2)/(n+1)
*/
BigInteger dp[] = new BigInteger[150];
dp[1]=BigInteger.valueOf(1);
for(int i=2;i<=100;i++) {
dp[i]=dp[i-1].multiply(BigInteger.valueOf(4*i-2)).divide(BigInteger.valueOf(i+1));
} while(cin.hasNext()) {
int n=cin.nextInt();
System.out.println(dp[n]);
}
}
}