13-Oulipo(kmp裸题)

时间:2023-03-10 04:51:44
13-Oulipo(kmp裸题)

  http://acm.hdu.edu.cn/showproblem.php?pid=1686              

              Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17533    Accepted Submission(s): 6963

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
Source
Recommend
lcy   |   We have carefully selected several similar problems for you:  1358 1711 3336 3746 2203 
思路:kmp裸题
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
string str, mo;
int Next[1000005]; void getNext(){
Next[0] = -1; //一定要初始化
int i = 0, j = -1, len = mo.length();
while(i < len){
if(j == -1 || mo[i] == mo[j]) //j表示前i-1个字符中前缀和后缀相等的长度
Next[++i] = ++j; //如果跳转的值相同,则Next的下一位对应的为前一位加一
else
j = Next[j]; //j回溯
}
} int kmp(){
int ans = 0;
int i = 0, j = 0, l1 = str.length(), l2 = mo.length();
while(i < l1){
if(j == -1 || str[i] == mo[j])
i++, j++;
else
j = Next[j]; //只需回溯j
if(j == l2) //在原串中找到一个模式串
ans++;
}
return ans;
} int main(){
ios::sync_with_stdio(false); //取消cin 与 scanf()同步,刚刚没加超时了
int t;
cin >> t;
while(t--){
// scanf("%s%s", &mo, &str);
cin >> mo >> str;
getNext();
// for(int i = 0; i < mo.length(); i++){
// cout << Next[i] << " ";
// }
// cout << endl;
printf("%d\n", kmp());
}
return 0;
}