hdu Red and Black

时间:2023-03-08 22:18:47
hdu Red and Black

算法:深搜

题意:就是让你找到一共可以移动多少次,每次只能移到黑色格子上,

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.



Write a program to count the number of black tiles which he can reach by repeating the moves described above.






Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.



There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.



'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)





Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).






Sample Input

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0





Sample Output

45

59

6

13

代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <iomanip>
using namespace std;
char ch[25][25];
int k,n,m;
void dfs(int x,int y,int &k)
{
ch[x][y]='#';
if(x-1>=0&&x-1<m&&y>=0&&y<n&&ch[x-1][y]=='.')
{k++;dfs(x-1,y,k);}
if(x+1<m&&x+1>=0&&y>=0&&y<n&&ch[x+1][y]=='.')
{k++;dfs(x+1,y,k);}
if(y-1>=0&&y-1<n&&x>=0&&x<m&&ch[x][y-1]=='.')
{k++;dfs(x,y-1,k);}
if(y+1<n&&y+1>=0&&x>=0&&x<m&&ch[x][y+1]=='.')
{k++;dfs(x,y+1,k);}
else return ;
}
int main()
{
int i,j,q,p;
while(cin>>n>>m&&n&&m)
{ k=1;
for(i=0;i<m;i++)
{
for(j=0;j<n;j++)
{
cin>>ch[i][j];
if(ch[i][j]=='@')
{
p=i;q=j;
}
} }
dfs(p,q,k);
cout<<k<<endl;
}
return 0;
}