POJ 3176 Cow Bowling

时间:2023-03-08 16:35:48
POJ 3176 Cow Bowling
Cow Bowling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13016   Accepted: 8598

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:
          7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:
          7

*

3 8

*

8 1 0

*

2 7 4 4

*

4 5 2 6 5

The highest score is achievable by traversing the cows as shown above.

Source

#include <cstdio>
int a[355][355];
int dp[355][355];
int main ()
{int i,j,n;
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
scanf("%d",&a[i][j]);

for(j=1;j<=n;j++)
dp[n][j]=a[n][j];

for(i=n-1;i>0;i--)
for(j=1;j<=i;j++)

if(dp[i+1][j]>dp[i+1][j+1])
dp[i][j]=a[i][j]+dp[i+1][j];

else dp[i][j]=a[i][j]+dp[i+1][j+1];

printf("%d\n",dp[1][1]);
}
return 0;
}

居然把i-- 习惯性的写成了i++; “for(i=n-1;i>0;i--)”