King's Quest —— POJ1904(ZOJ2470)Tarjan缩点

时间:2023-03-08 18:56:07

King’s Quest


  • Time Limit: 15000MS Memory Limit: 65536K

    Case Time Limit: 2000MS

Description

Once upon a time there lived a king and he had N sons. And there were N beautiful girls in the kingdom and the king knew about each of his sons which of those girls he did like. The sons of the king were young and light-headed, so it was possible for one son to like several girls.

So the king asked his wizard to find for each of his sons the girl he liked, so that he could marry her. And the king’s wizard did it – for each son the girl that he could marry was chosen, so that he liked this girl and, of course, each beautiful girl had to marry only one of the king’s sons.

However, the king looked at the list and said: “I like the list you have made, but I am not completely satisfied. For each son I would like to know all the girls that he can marry. Of course, after he marries any of those girls, for each other son you must still be able to choose the girl he likes to marry.”

The problem the king wanted the wizard to solve had become too hard for him. You must save wizard’s head by solving this problem.

Input

The first line of the input contains N – the number of king’s sons (1 <= N <= 2000). Next N lines for each of king’s sons contain the list of the girls he likes: first Ki – the number of those girls, and then Ki different integer numbers, ranging from 1 to N denoting the girls. The sum of all Ki does not exceed 200000.

The last line of the case contains the original list the wizard had made – N different integer numbers: for each son the number of the girl he would marry in compliance with this list. It is guaranteed that the list is correct, that is, each son likes the girl he must marry according to this list.

Output

Output N lines.For each king’s son first print Li – the number of different girls he likes and can marry so that after his marriage it is possible to marry each of the other king’s sons. After that print Li different integer numbers denoting those girls, in ascending order.

Sample Input

4

2 1 2

2 1 2

2 2 3

2 3 4

1 2 3 4

Sample Output

2 1 2

2 1 2

1 3

1 4

Hint

This problem has huge input and output data,use scanf() and printf() instead of cin and cout to read data to avoid time limit exceed.

Source

Northeastern Europe 2003

题意 :国王有n个儿子,同时在他的王国里有n个漂亮的女孩,国王知道他的儿子喜欢那些女孩(不止一个哦),国王要求谋士为他的每一个儿子挑一个他喜欢的女孩,让他的儿子娶这个女孩,每一个女孩只能嫁给一个国王的儿子,当国王看到谋士给他的选择名单后,不是很满意,他需要知道他的儿子可以和哪些女孩结婚,当然只要他和选择女孩结婚,其他的兄弟就能选到他喜欢的其他女孩结婚。

思路 : 可以将儿子与女孩之间的关系看做边,人看做点,建立有向图儿子[1,n],女孩[n+1,2n]。由于名单的原因,所以每一个儿子在可以结婚的女孩中必有名单上的女孩,所以可以在名单上的女孩和对应的儿子之间建立一条边,使得儿子和女孩处于同一个强连通分量中,建立图以后可以发现强连通分量中的元素的女孩是都可以娶的,再找出他喜欢的就是对应儿子可以娶的。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <algorithm> using namespace std; const int MaxM = 210000; const int MaxN = 4100; vector<int>Map[MaxN]; int dfn[MaxN],low[MaxN],vis[MaxN],dep; int pre[MaxN],num; vector<int>Gnum[MaxN]; stack <int> S; int n; void Init()
{
memset(vis,0,sizeof(vis)); for(int i=0;i<=2*n;i++)
{
Gnum[i].clear();
Map[i].clear();
} dep = 0; num = 0 ;
} void Tarjan(int u) //Tarjan缩点
{
dfn[u] = low[u] = dep++; vis[u] = 1; S.push(u); for(int i = 0 ;i<Map[u].size();i++)
{
int v = Map[u][i]; if(vis[v]==1)
{
low[u] = min(low[u],dfn[v]);
}
else if(vis[v]==0)
{
Tarjan(v); low[u] = min(low[u],low[v]);
}
} if(dfn[u] == low[u])
{
while(!S.empty())
{
int v = S.top(); S.pop(); pre[v] = num; vis[v] = 2; if(v == u)
{
break;
}
} num++;
}
}
int Scan() //输入外挂
{
int res=0,ch,flag=0;
if((ch=getchar())=='-')
flag=1;
else if(ch>='0'&&ch<='9')
res=ch-'0';
while((ch=getchar())>='0'&&ch<='9')
res=res*10+ch-'0';
return flag?-res:res;
}
void Out(int a) //输出外挂
{
if(a>9)
Out(a/10);
putchar(a%10+'0');
} int main()
{
while(~scanf("%d",&n))
{
Init(); int v,Ki; for(int i=1;i<=n;i++)
{
Ki = Scan(); for(int j=1;j<=Ki;j++)
{ v = Scan(); Map[i].push_back(v+n);
}
} for(int i=1;i<=n;i++)
{
v = Scan(); Map[v+n].push_back(i);
} for(int i=1;i<=n;i++) //使每一个儿子喜欢的女孩编号有序
{
sort(Map[i].begin(),Map[i].end());
} for(int i=1;i<=n;i++)
{
if(vis[i]==0)
{
Tarjan(i); }
} for(int i=1;i<=n;i++)
{ int ans = 0; for(int j = 0;j<Map[i].size();j++)
{
if(pre[i]==pre[Map[i][j]])//处于同一个强连通分量为可娶的。
{
ans++;
}
} Out(ans); for(int j=0;j<Map[i].size();j++)
{
if(pre[i]==pre[Map[i][j]])
{
putchar(' ');
Out(Map[i][j]-n);
}
} puts("");
}
// puts(""); ZOJ多一个换行 }
return 0;
}