hdoj 5500 Reorder the Books

时间:2023-03-09 23:22:29
hdoj 5500 Reorder the Books

Reorder the Books

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 919    Accepted Submission(s):
501

Problem Description
dxy has a collection of a series of books called "The
Stories of SDOI",There are n(n≤19)hdoj 5500 Reorder the Books

books in this series.Every book has a number from 1hdoj 5500 Reorder the Books

to nhdoj 5500 Reorder the Books

.

dxy puts these books in a book stack with the order of their numbers
increasing from top to bottom. dxy takes great care of these books and no one is
allowed to touch them.

One day Evensgn visited dxy's home, because dxy
was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn
was curious about this series of books.So he took a look at them. He found out
there was a story about "Little E&Little Q". While losing himself in the
story,he disrupted the order of the books.

Knowing that dxy would be back
soon,Evensgn needed to get the books ordered again.But because the books were
too heavy.The only thing Evensgn could do was to take out a book from the book
stack and and put it at the stack top.

Give you the order of the
disordered books.Could you calculate the minimum steps Evensgn would use to
reorder the books? If you could solve the problem for him,he will give you a
signed book "The Stories of SDOI 9: The Story of Little E" as a gift.

Input
There are several testcases.

There is an
positive integer T(T≤30)hdoj 5500 Reorder the Books

in the first line standing for the number of testcases.

For each
testcase, there is an positive integer nhdoj 5500 Reorder the Books

in the first line standing for the number of books in this
series.

Followed nhdoj 5500 Reorder the Books

positive integers separated by space standing for the order of the disordered
books,the ithhdoj 5500 Reorder the Books

integer stands for the ithhdoj 5500 Reorder the Books

book's number(from top to bottom).

Hint:
For the first
testcase:Moving in the order of book3,book2,book1hdoj 5500 Reorder the Books

,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4)hdoj 5500 Reorder the Books

,and this is the best way to reorder the books.
For the second testcase:It's
already ordered so there is no operation needed.

Output
For each testcase,output one line for an integer
standing for the minimum steps Evensgn would use to reorder the books.
Sample Input
2
4
4 1 2 3
5
1 2 3 4 5
Sample Output
3
题意:一摞书顺序乱了,让你按照序号从小到大的顺序将其排列整齐,一次只能拿一本书,且必须放在最上边,问最少多少步可以实现
题解:先算出已经按顺序排好的书本的个数sum(注意这个序列并不一定连续,而且必须是从某个数到n的序列),用n减去sum即可
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define MAX 100100
using namespace std;
int a[MAX];
int main()
{
int n,m,t,i,j;
scanf("%d",&t);
int maxx,ans;
while(t--)
{
scanf("%d",&n);
maxx=0;
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
if(maxx<a[i])
{
maxx=a[i];
ans=i;
}
}
int ant=ans,sum=0;
for(j=ans;j>=1;j--)
{
if(a[j]==a[ant]-1)
{
sum++;
ant=j;
}
}
printf("%d\n",n-sum-1);
}
return 0;
}