【暑假】[实用数据结构]UVAlive 3135 Argus

时间:2023-03-08 20:03:00

UVAlive 3135 Argus

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

【暑假】[实用数据结构]UVAlive 3135 Argus

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: �Every five minutes, retrieve the maximum temperature over the past five minutes.� Query-2: �Return the average temperature measured on each floor over the past 10 minutes.�

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period

Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of �#�.

The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005 -------------------------------------------------------------------------------------------------------------------------------------------------------- 思路
优先队列模拟。时间小的优先级高,每次选取time最小的出队记录Qnum后修改time重新入队(意味着该任务进入下一轮)
注意:优先队列中重载运算符比较特殊,我这样理解:STL中默认priority_queue为大根堆,而我们所需要的是小根堆,因此将 < 重载为相反符号。 代码:
 //处理器模拟
#include<cstdio>
#include<queue>
#define FOR(a,b,c) for(int a=(b);a<(c);a++)
using namespace std; struct Node{
int qnum,period,time;
bool operator < (const Node& rhs) const{
return time>rhs.time || (time==rhs.time && qnum>rhs.qnum);
}
};
//优先队列默认为大根堆,而需要的是“小根堆 ”因此相反地定义 < int main(){
priority_queue<Node> Q;
char s[];
Node x; while(scanf("%s",s) && s[] != '#'){
scanf("%d%d",&x.qnum,&x.period);
x.time=x.period; //time_init
Q.push(x);
}
int k; scanf("%d",&k);
while(k--){
x=Q.top(); Q.pop();
printf("%d\n",x.qnum);
x.time += x.period; //更改为下一轮的时间重新放回优先队列
Q.push(x);
}
return ;
}