hdoj:2080

时间:2023-03-10 01:44:15
hdoj:2080

夹角有多大II

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10656    Accepted Submission(s): 5510


Problem Description
这次xhd面临的问题是这样的:在一个平面内有两个点,求两个点分别和原点的连线的夹角的大小。

注:夹角的范围[0,180],两个点不会在圆心出现。

Input
输入数据的第一行是一个数据T,表示有T组数据。
每组数据有四个实数x1,y1,x2,y2分别表示两个点的坐标,这些实数的范围是[-10000,10000]。

Output
对于每组输入数据,输出夹角的大小精确到小数点后两位。

Sample Input
2
1 1 2 2
1 1 1 0

Sample Output
0.00
45.00
#include <iostream>
#include <string>
#include <cstdlib>
#include <stdio.h>
#include <cmath>
#define PI 3.141592653
using namespace std; int main()
{
int T;
double x1, y1, x2, y2;
double a,b,cosx, arcosx;
cin >> T;
while (T--)
{
cin >> x1 >> y1 >> x2 >> y2;
a = x1*x2 + y1*y2;
b = sqrt((x1*x1 + y1*y1)*(x2*x2 + y2*y2));
cosx = a / b;
arcosx = acos(cosx) /PI *180;
printf("%.2lf\n", arcosx);
}
return 0;
}